Download

FH307 Firmware V5.07.64_EN

 

Update:

1.Added English as the default language.

2.Low Power as the defaulty.

3.Added the function of Dial-up access the internet with PPTP\L2TP.


Notes:

1.This firmware is only fit for FH307 and its firmware version must be in V5.07.xx .

2.Incorrect upgrade will damage your device.

3.Please upgrade your device by cable connections.

4.Do not power off the device when upgrading.

5.Please unzip the file you downloaded and use the file ended with "bin" or "trx" to upgrade your device.




Please contact us if you have questions support.usa@tenda.com.cn,thanks!